Artikelformat

Ubuntu 9.10 Karmic und das UMTS Problem

Vorgestern war großer Linux-Update-Tag bei mir. Ich stellte die Ubuntu-Installation auf meinem Samsung NC10 Netbook mit integriertem UMTS-Modem von 9.04 auf 9.10 um und wollte wie gewohnt weiter arbeiten…

Bild 4.jpg

Dies konnte ich nur bedingt, denn aus irgendwelchen Gründen konnte ich mich nicht mehr mit dem Mobilen Breitband verbinden.

Bild 3.jpg Bild 2.jpg

Es kam fortlaufend folgende Fehlermeldung:

GSM Netzwerk

Verbindung getrennt, Sie sind nun offline.

Unzählige Foreneinträge später hatte ich die Lösung des Problems gefunden. Es liegt, traurig aber wahr, an dem nicht korrekten Zusammenspiel des internen HSDPA Modem meines Samsung NC10 und dem Ubuntu Network Manager. Dieser Bug scheint es tatsächlich irgendwie von der Beta in die aktuelle Version von Karmic geschafft zu haben.

Fehlerbehebung

  • Als allererstes sollte man die daily trunk builds des Netzwerkmanagers seinen Ubuntu Softwarequellen hinzufügen.
  • Danach seine Softwarepakete updaten…
    • sudo apt-get update
    • sudo apt-get upgrade
  • …und schließlich den Netzwerkmanager bzw. Ubuntu selbst neu starten lassen.
    • sudo /etc/init.d/network-manager restart

Abschließend überprüft man am besten nochmal die Einstellungen seines Providers. In meinem Fall ist das maXXim, die ja bekanntlich das T-Mobile Netz nutzen und dem erneuten Surfvergnügen via UMTS steht nichts mehr im Wege.

Bild 8.jpg Bild 6.jpg

Autor: Björn

Ich bin Björn und quasi der COO von aptgetupdateDE. Ich kümmere mich um die PR und allerlei Kontaktaufnahmen zu Firmen und Softwareentwicklern. Erreichbar bin ich bei Twitter, App.net und natürlich per E-Mail.

15 Kommentare

  1. Seit 9.10 funktioniert bei mir Drucker-Sharing im Netzwerk nicht mehr. Hab schon vieles versucht, aber die Macs sehen einfach keine Drucker…

  2. leider kann ich nichts sinnvolles zur problemlösung beisteuern, aber das wallpaper gefällt mir recht gut. hast du zufällig nen link? ;)

  3. @Lafayette: Wie Sinnvolles zur Problemlösung?! Das Problem ist doch gelöst ;)

    Das Wallpaper reiche ich dir nach, sobald ich wieder an der Linuxkiste sitze (wird aber erst kommendes Jahr soweit sein).

  4. Hallo Björn,

    ich habe das gleiche Problem mit meinem eee pc 100H Go. Habe auch deinen Lösungsweg versucht, leider erfolglos :-(. Hättest du manchmal noch einen Tip oder eine Idee?

    Vielen Dank schon mal!
    Sascha

  5. Ich habe T-Mobile und habe es mit 2 verschiedenen Einstellungen probiert:

    1.
    Nummer: *99#
    Benutzername: t-mobile
    Passwort: tm
    APN: internet.t-mobile
    bzw. APN: internet-t-mobile.de

    2.
    Nummer: *99#
    Benutzername:
    Passwort: t-d1
    APN: internet.t-d1.de

    Habe auch bei beiden die Nummer „*99***1#“ getestet. Alles ohne Erfolg.

  6. Also ich habe bei mir folgende Einstellungen:

    Nummer: *99#
    Benutzername: tm
    Passwort: tm
    APN: internet.t-mobile

    Und zusätzlich noch die PIN eingetragen, damit ich die nicht immer eingeben muss.

    Funktioniert tadellos.

    Es gibt derzeit auch ziemlich häufig n neues Nightly Build des Netzwerkmanagers. Funktionierte das Ganze denn vorher unter Ubuntu 9.04 problemlos oder hattest du das nie installiert?

  7. Ich hatte schon Ubuntu 9.04 und auch eeebuntu 3.0 drauf. Umts lief noch nie. Habe es auch mit deinen Einstellungen versucht aber leider ohne Erfolg. Denke es liegt direkt an dem Asus Modell. Konnte im Netz aber auch keine Einträge finden die mir weiterhelfen.

  8. Pingback: Samsung NC10 Anynet (HAT2DE), Ubuntu Karmic Koala and UMTS « Christian's blog

  9. Habe es jetzt hinbekommen. Mein Modem war gelocked (obwohl ich es auch mit der Vodafone Simkarte meines Vertrages getestet habe).

    Habe unter XP, zwei Firmwareupdates für das Modem gemacht und nach dem Test mit 3 Einwahlprogrammen getestet bis die Lock Meldung mal kam.

    Trotzdem Vielen Dank!

  10. Hallo Björn,

    danke für den Tip, jetzt läuft mein Hsdpa-Modem mit Vodafone.

    Allerdings bekomme ich jetzt keine W-lan verbindung mehr.
    hin.

    Kannst du mir da vielleicht noch helfen?

    Gruß Thomas

    • Hallo,

      ich konnte das Problem etwas eingrenzen.
      Die Adresszuweisung über DHCP funktioniert nur nicht.
      Wenn ich die Adressen manuell zuweise geht es.

      Ist zwar jetzt nicht ganz schon schön, aber auf jedenfall besser als wenn es gar nicht geht.

      Gruß Thomas

      • Puhh, gute Frage. Hört sich erstmal wieder nach nem Bug im Networkmanager an. Schau am besten mal bei denen ins Forum.

        Und um ehrlich zu sein. So viel Trouble hatte ich mit bisher keinen anderen Ubuntu Version. Bleibt zu hoffen, dass das bald erscheinende 10.04 etwas stabiler läuft.

  11. Aloha

    Ich habe auch ein Samsung NC10 und nach dem Update von 9.10 auf 10.04 bekomme ich keine Verbindung mehr.
    Habe es wie oben beschrieben versucht aber ohne Erfolg, es wurde keine Aktualiesrung angeziegt.
    Gibt es noch andere Möglichkeiten?
    Ach ja,ich gehe über O2 ins Netz.